FAQ FAQ  Forum Search   Events   Register Register  Login Login

TechArt Pro LM-EA7 firmware update issue/solution

Author
EddyH View Drop Down
Senior Member
Senior Member

Joined: 22 August 2010
Country: Belgium
Location: Antwerp
Status: Offline
Posts: 434
Post Options Post Options   Quote EddyH Quote  Post ReplyReply Direct Link To This Post Topic: TechArt Pro LM-EA7 firmware update issue/solution
    Posted: 03 May 2019 at 11:29
This post is more for future reference than discussion: I recently bought the TechArt LM-EA7 adapter, to be able to use M-mount lenses on Sony E-mount and this with autofocus... What triggered my purchase was a review by Albert Dross showing that also Eye AF now works on this adapter. Which will add AF to almost any MF lens (you can use e.g. Minolta MD to Leica M adapters to use MD lenses on the TechArt and give them autofocus).

When trying to update the firmware, however, the adapter wasn't recognized. After a brief search I found the reason: there is one element missing in the description on the TechArt website: you need to put the camera in M-mode when setting the aperture to F90...

And it seems you also need to make sure the airplane mode is off.

So this is the complete and correct procedure.

1) Make sure the battery level of your camera and phone is >50%
2) Make sure the Auto-Lock of your phone is OFF
3) Plug in the adapter to your camera body
4) Turn ON the camera, make sure the 'airplane mode' is OFF, set the camera to M-mode, change the aperture value to F/90 (not F/9 !), release the shutter
5) Turn OFF the camera (IMPORTANT!)
6) Run the app in the smartphone and select the firmware 3.0 under LM-EA7
7) Click ‘Update’
8) Wait around 10 mins for the update to complete
9) SUCCESS

Hope this helps if anyone ever needs it...

Eddy
2 eyes | 2 slices of silicon | a few kilos of glass | my photo blog
 



Back to Top
Dopol View Drop Down
Alpha Eyes group
Alpha Eyes group

Joined: 17 May 2007
Country: Netherlands
Location: Amsterdam
Status: Online
Posts: 6796
Post Options Post Options   Quote Dopol Quote  Post ReplyReply Direct Link To This Post Posted: 03 May 2019 at 20:08
Thanks for heads up
I have one
I'll give the update a try tomorrow
previous updates did work well
and I still like my Techart pro
Be yourself; everyone else is already taken
Back to Top
C_N_RED_AGAIN View Drop Down
Senior Member
Senior Member

Joined: 05 July 2007
Location: United States
Status: Offline
Posts: 1207
Post Options Post Options   Quote C_N_RED_AGAIN Quote  Post ReplyReply Direct Link To This Post Posted: 03 May 2019 at 23:48
Great advice thankyou
Back to Top
Dopol View Drop Down
Alpha Eyes group
Alpha Eyes group

Joined: 17 May 2007
Country: Netherlands
Location: Amsterdam
Status: Online
Posts: 6796
Post Options Post Options   Quote Dopol Quote  Post ReplyReply Direct Link To This Post Posted: 07 May 2019 at 07:49
I installed the newest software version (Version 6.0 of20180105)
A warning: use the latest version of Techart installation software.
That requires to uninstall the software
look it up in the app store and reinstall it.
The older version freezes during the install process
But then it all works
It does eye AF, be it a little sluggish.
Be yourself; everyone else is already taken
Back to Top
Dyxum main page >  Forum Home > Equipment forums > Lens Talk > Adapters and converters

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.080 seconds.

Monitor calibration strip

Dyxum.com - Home of the alpha system photographer

In memory of Cameron Hill - brettania

Feel free to contact us if needed.