FAQ FAQ  Forum Search   Events   Register Register  Login Login

A77 not working

Author
ABDurbs View Drop Down
Senior Member
Senior Member

Joined: 27 October 2011
Country: South Africa
Location: Durban
Status: Offline
Posts: 919
Post Options Post Options   Quote ABDurbs Quote  Post ReplyReply Direct Link To This Post Topic: A77 not working
    Posted: 09 January 2019 at 10:17
I am posting this on behalf of a Sony acquaintance situated in Lusaka, Zambia. My answer to him was that he has damaged his A77 by attaching his friends damaged lenses and that he probably has to send the camera to a service centre. If there is an alternative fix, please let me know. He has already tried to do a firmware 2 reinstall, but he claims there is no software update when using iOS 10.13. Thanks

"A friend of mine with the A77 came over this afternoon with trouble. His 70-300mm G Master lens and 28mm were not reading on his camera. I tried them on my A77II and they didn;t work as well

Now i have put on my 16-50mm and 55-300mm on my camera.... Both can't be read by the camera.

Pins and contacts have been cleaned. There's no sign of any physical damage to the lens contacts or the pins

Help! I have a shoot in the morning"

Edited by ABDurbs - 09 January 2019 at 10:20
Regards
Allan
A99 + VG, A77ii + VG, 70-400G, Zeiss 85mm f1.7, CZ16-80, Tamron 70-200 USD Tamron 24-70 USD, HVL-43AM, Godox TT685S & X1T-S, Minolta 8000i, Minolta 50mm f1.7
 



Back to Top
stiuskr View Drop Down
Moderator Group
Moderator Group

Joined: 01 September 2006
Country: United States
Location: West Virginia
Status: Offline
Posts: 11341
Post Options Post Options   Quote stiuskr Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 11:48
"...My answer to him was that he has damaged his A77 by attaching his friends damaged lenses and that he probably has to send the camera to a service centre..."

I agree, there's no easy fix and it'll take some diag and a part replacement to fix this. Last year Photosopher bought a used lens that killed the camera when he went to test it.

Firmware can not be re-installed and can only be updated to a later version.

Edited by stiuskr - 09 January 2019 at 11:51
Rob Suits Jr.
a99M2 a99 a77 a700 KM7D|Min24/2.8 Min35/2 So50/1.4 So50/2.8 Min85/1.4G Tam90/2.8 Tam180/3.5|Tam17-50 CZ24-70G2 KM28-75D So70-200G1 So70-300G So70-400G1| SonyF60 AD200R2
Back to Top
ABDurbs View Drop Down
Senior Member
Senior Member

Joined: 27 October 2011
Country: South Africa
Location: Durban
Status: Offline
Posts: 919
Post Options Post Options   Quote ABDurbs Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 11:52
Thanks Rob exactly as I thought. It's a nightmare for him as there are no Sony agents in Zambia, so he will have to send it to South Africa
Regards
Allan
A99 + VG, A77ii + VG, 70-400G, Zeiss 85mm f1.7, CZ16-80, Tamron 70-200 USD Tamron 24-70 USD, HVL-43AM, Godox TT685S & X1T-S, Minolta 8000i, Minolta 50mm f1.7
Back to Top
QuietOC View Drop Down
Senior Member
Senior Member

Joined: 28 February 2015
Country: United States
Location: Michigan
Status: Offline
Posts: 2567
Post Options Post Options   Quote QuietOC Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 13:29
This sounds like the in-lens motor drive fuses are blown in the camera. Those surface mount fuses shouldn't be very hard to replace. A local electronics repairman should be able to replace them. I don't know where they are located--probably on the outer surface of the main camera PCB--or what size they are.

Edited by QuietOC - 09 January 2019 at 13:44
Sony A7II A77II LA-EA3 LA-EA4 MC-11
Minolta Maxxum 600si
Pentax Q7 5-15 15-45/2.8
Back to Top
mirthseeker View Drop Down
Senior Member
Senior Member

Joined: 02 October 2011
Country: Australia
Location: Melbourne
Status: Offline
Posts: 693
Post Options Post Options   Quote mirthseeker Quote  Post ReplyReply Direct Link To This Post Posted: 10 January 2019 at 01:30
This dpreview thread might help give clues to the location of the surface-mounted fuses, their values, and possible sources.
Back to Top
ABDurbs View Drop Down
Senior Member
Senior Member

Joined: 27 October 2011
Country: South Africa
Location: Durban
Status: Offline
Posts: 919
Post Options Post Options   Quote ABDurbs Quote  Post ReplyReply Direct Link To This Post Posted: 10 January 2019 at 07:32
Thanks guys will pass on the info.
Regards
Allan
A99 + VG, A77ii + VG, 70-400G, Zeiss 85mm f1.7, CZ16-80, Tamron 70-200 USD Tamron 24-70 USD, HVL-43AM, Godox TT685S & X1T-S, Minolta 8000i, Minolta 50mm f1.7
 



Back to Top
Dyxum main page >  Forum Home > Equipment forums > Camera Talk

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.047 seconds.

Monitor calibration strip

Dyxum.com - Home of the alpha system photographer

In memory of Cameron Hill - brettania

Feel free to contact us if needed.