FAQ FAQ  Forum Search   Events   Register Register  Login Login

A-Mount Teleconverters Guide

Page  <1 26272829>
Author
Miranda F View Drop Down
Senior Member
Senior Member

Joined: 11 January 2014
Country: United Kingdom
Location: Bristol
Status: Offline
Posts: 3511
Post Options Post Options   Quote Miranda F Quote  Post ReplyReply Direct Link To This Post Posted: 29 January 2018 at 14:08
There are some funnies with particular combos. I can't get my Sony 55-300mm to even attenpt to AF with the 1.4x DGX TC, though the TC works fine with lots of other lenses.
Miranda F & Sensorex, Sony A58, Nex-6, Dynax 4, 5, 60, 500si/600si/700si/800si, various Sony & Minolta lenses, several Tamrons, lots of MF primes and *far* too many old film cameras . . .
 



Back to Top
Mark_k View Drop Down
Senior Member
Senior Member

Joined: 20 January 2006
Country: Hong Kong
Location: Hong Kong
Status: Offline
Posts: 996
Post Options Post Options   Quote Mark_k Quote  Post ReplyReply Direct Link To This Post Posted: 29 January 2018 at 15:57
Yes..all my older lenses work extremely well.
Mark K A99II A7rII, A77, A6k, RX100III
Back to Top
QuietOC View Drop Down
Senior Member
Senior Member

Joined: 28 February 2015
Country: United States
Location: Michigan
Status: Offline
Posts: 2917
Post Options Post Options   Quote QuietOC Quote  Post ReplyReply Direct Link To This Post Posted: 29 January 2018 at 16:20
Originally posted by Mark_k Mark_k wrote:

Yes..all my older lenses work extremely well.

Your "DGX" teleconverter seems to be acting just like my non-DGX Kenko. That one works great with any screw-drive lens, and not with any motorized lens. Can you post a picture of it?
Sony A7III NEX-5T HVL-F45RM LA-EA3 LA-EA4 MB-IV MC-11 EF-E II MD-NEX KR-NEX DA-NEX
Minolta Maxxum 600si
Pentax Q7 5-15 15-45/2.8 8.5/1.9 11.5/9 AF-P/Q
Back to Top
Miranda F View Drop Down
Senior Member
Senior Member

Joined: 11 January 2014
Country: United Kingdom
Location: Bristol
Status: Offline
Posts: 3511
Post Options Post Options   Quote Miranda F Quote  Post ReplyReply Direct Link To This Post Posted: 30 January 2018 at 10:13
My DGX does work with some motorised lenses, just not the 55-300mm.
Miranda F & Sensorex, Sony A58, Nex-6, Dynax 4, 5, 60, 500si/600si/700si/800si, various Sony & Minolta lenses, several Tamrons, lots of MF primes and *far* too many old film cameras . . .
Back to Top
craig66 View Drop Down
Senior Member
Senior Member

Joined: 03 April 2012
Country: Australia
Status: Offline
Posts: 637
Post Options Post Options   Quote craig66 Quote  Post ReplyReply Direct Link To This Post Posted: 30 January 2018 at 10:23
Originally posted by QuietOC QuietOC wrote:

Originally posted by Mark_k Mark_k wrote:

Yes..all my older lenses work extremely well.

Your "DGX" teleconverter seems to be acting just like my non-DGX Kenko. That one works great with any screw-drive lens, and not with any motorized lens. Can you post a picture of it?


I have the Kenko 1.4x DGX. AF works with Sony DT 16-50 f2.8 SSM, Tamron 60mm f2 macro, Sigma 105 f2.8 OS HSM macro and Sigma 150mm f2.8 OS HSM macro. AF does not work with Sony DT 55-300 or Sony DT 35mm f1.8. So maybe some issue with SAM lenses?

I don't have much reason to use a TC with any of those lenses except perhaps the 150mm Sigma. I really only use the Kenko with a Sigma 500mm f4.5 EX DG and it works quite well for that.

EDIT: I should add that the camera is A77ii.

Edited by craig66 - 30 January 2018 at 10:32
Back to Top
QuietOC View Drop Down
Senior Member
Senior Member

Joined: 28 February 2015
Country: United States
Location: Michigan
Status: Offline
Posts: 2917
Post Options Post Options   Quote QuietOC Quote  Post ReplyReply Direct Link To This Post Posted: 30 January 2018 at 11:39
I pretty much only use the DGX teleconverters on my 55-300. That combination works on all the bodies I have: Maxxum 50 & 70, A58, A65, A68, A5000 + LA-EA1. My only issue is the focal lengths and apertures not getting corrected.
Sony A7III NEX-5T HVL-F45RM LA-EA3 LA-EA4 MB-IV MC-11 EF-E II MD-NEX KR-NEX DA-NEX
Minolta Maxxum 600si
Pentax Q7 5-15 15-45/2.8 8.5/1.9 11.5/9 AF-P/Q
 



Back to Top
HILLCLIMBER View Drop Down
Groupie
Groupie

Joined: 24 February 2011
Country: United Kingdom
Location: North Devon
Status: Offline
Posts: 137
Post Options Post Options   Quote HILLCLIMBER Quote  Post ReplyReply Direct Link To This Post Posted: 30 January 2018 at 22:51


I don't have much reason to use a TC with any of those lenses except perhaps the 150mm Sigma. I really only use the Kenko with a Sigma 500mm f4.5 EX DG and it works quite well for that.

EDIT: I should add that the camera is A77ii. [/QUOTE]

I use the same setup (A77Mk2 Sigma 500 f4.5 EX DG and Kenko DGX ) and it works superbly complete with autofocus and there appears to be no noticeable drop in IQ, I had thought of using the matched Sigma 1.4 converter but from Sigma website it looks as if I would loose AF , has anyone else used the matched converter and found if it autofocuses or not?
Back to Top
Miranda F View Drop Down
Senior Member
Senior Member

Joined: 11 January 2014
Country: United Kingdom
Location: Bristol
Status: Offline
Posts: 3511
Post Options Post Options   Quote Miranda F Quote  Post ReplyReply Direct Link To This Post Posted: 31 January 2018 at 09:15
Originally posted by HILLCLIMBER HILLCLIMBER wrote:


I use the same setup (A77Mk2 Sigma 500 f4.5 EX DG and Kenko DGX ) and it works superbly complete with autofocus and there appears to be no noticeable drop in IQ, I had thought of using the matched Sigma 1.4 converter but from Sigma website it looks as if I would loose AF , has anyone else used the matched converter and found if it autofocuses or not?


Is that with centre-point focus, or any point?
Miranda F & Sensorex, Sony A58, Nex-6, Dynax 4, 5, 60, 500si/600si/700si/800si, various Sony & Minolta lenses, several Tamrons, lots of MF primes and *far* too many old film cameras . . .
Back to Top
HILLCLIMBER View Drop Down
Groupie
Groupie

Joined: 24 February 2011
Country: United Kingdom
Location: North Devon
Status: Offline
Posts: 137
Post Options Post Options   Quote HILLCLIMBER Quote  Post ReplyReply Direct Link To This Post Posted: 31 January 2018 at 23:36
Centre point.
Back to Top
QuietOC View Drop Down
Senior Member
Senior Member

Joined: 28 February 2015
Country: United States
Location: Michigan
Status: Offline
Posts: 2917
Post Options Post Options   Quote QuietOC Quote  Post ReplyReply Direct Link To This Post Posted: 18 May 2018 at 14:40
Originally posted by QuietOC QuietOC wrote:

I pretty much only use the DGX teleconverters on my 55-300. That combination works on all the bodies I have: Maxxum 50 & 70, A58, A65, A68, A5000 + LA-EA1. My only issue is the focal lengths and apertures not getting corrected.

The issue seems to be the DGX teleconverters don't support the latest A-mount communication speed. This faster communication speed is the main change in the SSM II lenses, and it also allows 10 FPS tracking with the A9/LA-EA3.

The list of lenses that support 10 FPS tracking on the A9 is likely also the list of lenses not fully compatible with the DGX teleconverters:

SAL1635Z2     Vario-Sonnar T* 16-35mm F2.8 ZA SSM II
SAL1650     DT 16-50mm F2.8 SSM
SAL18135     DT 18-135mm F3.5-5.6 SAM
SAL2470Z2     Vario-Sonnar T* 24-70mm F2.8 ZA SSM II
SAL50F14Z     Planar T* 50mm F1.4 ZA SSM
SAL55300     DT 55-300mm F4.5-5.6 SAM
SAL70200G2     70-200mm F2.8 G SSM II
SAL70300G2     70-300mm F4.5-5.6 G SSM II
SAL70400G2     70-400mm F4-5.6 G SSM II
SAL300F28G2     300mm F2.8 G SSM II
SAL500F40G     500mm F4 G SSM

All three of my lenses on this list do not get their aperture and focal length corrected by the DGX teleconverters on current Sony A-mount cameras (A65, A58, A68 for me.) The DGX teleconverters do correct them on Minolta bodies and on the LA-EA1 which was released a year before the oldest lens in the list--the SAL1650 in 2011. Probably the pre-2011 Sony A-mount bodies also don't support the faster communication speed.

It would be nice if there was a way to force the use of the slower protocol when using the DGX teleconverters. When I first tried the SAL1650 on a 1.4X DGX on the A68 this morning it seemed to be getting adjusted (F4 was the minimum), but remounting it made it revert. I'll investigate this further.

Edited by QuietOC - 18 May 2018 at 22:50
Sony A7III NEX-5T HVL-F45RM LA-EA3 LA-EA4 MB-IV MC-11 EF-E II MD-NEX KR-NEX DA-NEX
Minolta Maxxum 600si
Pentax Q7 5-15 15-45/2.8 8.5/1.9 11.5/9 AF-P/Q
Back to Top
Mark_k View Drop Down
Senior Member
Senior Member

Joined: 20 January 2006
Country: Hong Kong
Location: Hong Kong
Status: Offline
Posts: 996
Post Options Post Options   Quote Mark_k Quote  Post ReplyReply Direct Link To This Post Posted: 17 July 2018 at 00:32
Originally posted by Miranda F Miranda F wrote:

My DGX does work with some motorised lenses, just not the 55-300mm.

Here you go
Mark K A99II A7rII, A77, A6k, RX100III
Back to Top
Mark_k View Drop Down
Senior Member
Senior Member

Joined: 20 January 2006
Country: Hong Kong
Location: Hong Kong
Status: Offline
Posts: 996
Post Options Post Options   Quote Mark_k Quote  Post ReplyReply Direct Link To This Post Posted: 17 July 2018 at 00:34
Can we actually hack an LAEA1 to use on an A9?
Mark K A99II A7rII, A77, A6k, RX100III
Back to Top
QuietOC View Drop Down
Senior Member
Senior Member

Joined: 28 February 2015
Country: United States
Location: Michigan
Status: Offline
Posts: 2917
Post Options Post Options   Quote QuietOC Quote  Post ReplyReply Direct Link To This Post Posted: 17 July 2018 at 00:58
Originally posted by Mark_k Mark_k wrote:

Can we actually hack an LAEA1 to use on an A9?

The LA-EA1 should work on an A9, but it won't act like an updated LA-EA3.
Sony A7III NEX-5T HVL-F45RM LA-EA3 LA-EA4 MB-IV MC-11 EF-E II MD-NEX KR-NEX DA-NEX
Minolta Maxxum 600si
Pentax Q7 5-15 15-45/2.8 8.5/1.9 11.5/9 AF-P/Q
Back to Top
Nordlicht View Drop Down
Senior Member
Senior Member

Joined: 21 September 2018
Country: Germany
Location: North Germany
Status: Offline
Posts: 178
Post Options Post Options   Quote Nordlicht Quote  Post ReplyReply Direct Link To This Post Posted: 06 April 2019 at 12:07
Originally posted by Mark_k Mark_k wrote:

Originally posted by Miranda F Miranda F wrote:

My DGX does work with some motorised lenses, just not the 55-300mm.

Here you go


I recently bought the Kenko 1.4x MC4 DGX for 100 on ebay (identical to the one in the photo, 8 contacts), hoping that it will work with my Tamron SP 2.8/70-200mm but it doesn't

Dosn't work means, AF doesn't work and the aperture is only displayed as F--.
For the lenses that worked fine, AF worked well, the corrected aperture is displyed and the EXIF contained correct information, e.g. 1.4/30mm became 2.0/45mm.

So I checked all my lenses to see which one works and which don't work.

"screwdrive" AF:
Minolta 3.5-3-5/24-85mm     works
Sigma 4.5-5.6/75-300mm APO works
Tamron 4.5-5.6/80-210mm     works
Minolta 1.7/50mm            works

Lenses with own AF drive (HSM/USM/SSM)
Sigma 1.4/30mm DC HSM Art   works
Sigma 3.5/10-20mm           doesn't work
Tamron SP2.8/70-200mm       doesn't work
Sony DT3.5-5.6/18-55mm      doesn't work


The ebay seller has a 30 day return policy and agreed to take it back.
Back to Top
Dyxum main page >  Forum Home > Equipment forums > Lens Talk > Adapters and converters Page  <1 26272829>

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.109 seconds.

Monitor calibration strip

Dyxum.com - Home of the alpha system photographer

In memory of Cameron Hill - brettania

Feel free to contact us if needed.