FAQ FAQ  Forum Search   Events   Register Register  Login Login

HVL-F58AM flash on A77ii

Author
Rambler358 View Drop Down
Senior Member
Senior Member

Joined: 23 December 2005
Country: United States
Location: Torrance, CA
Status: Offline
Posts: 220
Post Options Post Options   Quote Rambler358 Quote  Post ReplyReply Direct Link To This Post Topic: HVL-F58AM flash on A77ii
    Posted: 19 March 2021 at 18:24
So I have the subject flash from my A77. In order to use this flash with my A77ii I need an adapter - is the Sony ADP_MAA the correct adapter to use?

And does the adapter offer the same full functionality of the flash as what I had with the A77?
~Ron
Torrance, CA
 



Back to Top
michelb View Drop Down
Senior Member
Senior Member

Joined: 26 August 2009
Country: Canada
Location: Montréal
Status: Offline
Posts: 676
Post Options Post Options   Quote michelb Quote  Post ReplyReply Direct Link To This Post Posted: 19 March 2021 at 18:32
Yes to both questions

Just ensure you tighten the adapter properly on the body since some people have dropped/lost their flash by slipping out of the hot shoe
Michel B
Back to Top
Rambler358 View Drop Down
Senior Member
Senior Member

Joined: 23 December 2005
Country: United States
Location: Torrance, CA
Status: Offline
Posts: 220
Post Options Post Options   Quote Rambler358 Quote  Post ReplyReply Direct Link To This Post Posted: 19 March 2021 at 18:46
Thank you!
~Ron
Torrance, CA
Back to Top
LAbernethy View Drop Down
Senior Member
Senior Member

Joined: 25 November 2015
Country: Canada
Location: Ajax, Ontario
Status: Offline
Posts: 2542
Post Options Post Options   Quote LAbernethy Quote  Post ReplyReply Direct Link To This Post Posted: 19 March 2021 at 20:15
Originally posted by michelb michelb wrote:

Yes to both questions

Just ensure you tighten the adapter properly on the body since some people have dropped/lost their flash by slipping out of the hot shoe

that would be me
Back to Top
Miranda F View Drop Down
Senior Member
Senior Member

Joined: 11 January 2014
Country: United Kingdom
Location: Bristol
Status: Offline
Posts: 3847
Post Options Post Options   Quote Miranda F Quote  Post ReplyReply Direct Link To This Post Posted: 19 March 2021 at 20:39
Um ... and me.
Miranda F & Sensorex, Sony A7Rii, A58, Nex-6, Dynax 4, 5, 60, 500si/600si/700si/800si, various Sony & Minolta lenses, several Tamrons, lots of MF primes and *far* too many old film cameras ...
Back to Top
Rambler358 View Drop Down
Senior Member
Senior Member

Joined: 23 December 2005
Country: United States
Location: Torrance, CA
Status: Offline
Posts: 220
Post Options Post Options   Quote Rambler358 Quote  Post ReplyReply Direct Link To This Post Posted: 19 March 2021 at 20:41
Originally posted by Miranda F Miranda F wrote:

Um ... and me.

Flash falling off, or firmware 2.0 issues?
~Ron
Torrance, CA
 



Back to Top
Miranda F View Drop Down
Senior Member
Senior Member

Joined: 11 January 2014
Country: United Kingdom
Location: Bristol
Status: Offline
Posts: 3847
Post Options Post Options   Quote Miranda F Quote  Post ReplyReply Direct Link To This Post Posted: 19 March 2021 at 20:42
Just falling off. No damage, fortunately. Never updated the firmware on my A58.*






*Maybe because there isn't one! They don't bother for lowly entry-level cameras.

Or maybe they just got it right first time? It doesn't do some things that other cameras do, but the things it does, it does rather well.



Or maybe they'd lost interest in A-mount by that time.

Edited by Miranda F - 19 March 2021 at 20:48
Miranda F & Sensorex, Sony A7Rii, A58, Nex-6, Dynax 4, 5, 60, 500si/600si/700si/800si, various Sony & Minolta lenses, several Tamrons, lots of MF primes and *far* too many old film cameras ...
Back to Top
michelb View Drop Down
Senior Member
Senior Member

Joined: 26 August 2009
Country: Canada
Location: Montréal
Status: Offline
Posts: 676
Post Options Post Options   Quote michelb Quote  Post ReplyReply Direct Link To This Post Posted: 19 March 2021 at 20:49
Originally posted by Rambler358 Rambler358 wrote:

Originally posted by Miranda F Miranda F wrote:

Um ... and me.

Flash falling off, or firmware 2.0 issues?


The only AM Flash that required a firmware was the HVL-F60M and this had to be done at a Sony service center.

The issue was to help reduce the overheating but once the firmware was installed, the recycling time went up.

No free lunch

Unless you were talking about a firmware for the A77II body ?
Michel B
Back to Top
Rambler358 View Drop Down
Senior Member
Senior Member

Joined: 23 December 2005
Country: United States
Location: Torrance, CA
Status: Offline
Posts: 220
Post Options Post Options   Quote Rambler358 Quote  Post ReplyReply Direct Link To This Post Posted: 20 March 2021 at 00:01
Unless you were talking about a firmware for the A77II body ?

Yeah, I was referring to the A77ii firmware.
~Ron
Torrance, CA
Back to Top
LAbernethy View Drop Down
Senior Member
Senior Member

Joined: 25 November 2015
Country: Canada
Location: Ajax, Ontario
Status: Offline
Posts: 2542
Post Options Post Options   Quote LAbernethy Quote  Post ReplyReply Direct Link To This Post Posted: 20 March 2021 at 00:01
Originally posted by Miranda F Miranda F wrote:

Um ... and me.

I managed to break one HVL-F42AM using an ADP-MAA and drown one in a fountain. I've dropped my HVL-F43M more than a few times; with no breakage. The problem is I still use cameras and flashes with the auto-lock accessory shoe.
Back to Top
Dyxum main page >  Forum Home > Equipment forums > Lighting

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.

Monitor calibration strip

Dyxum.com - Home of the alpha system photographer

In memory of Cameron Hill - brettania

Feel free to contact us if needed.