FAQ FAQ  Forum Search   Events   Register Register  Login Login

Minolta 100 2.8 macro cleaning & TC issue

Page  12>
Author
sakisf View Drop Down
Newbie
Newbie

Joined: 08 November 2018
Country: Greece
Location: Athens
Status: Offline
Posts: 12
Post Options Post Options   Quote sakisf Quote  Post ReplyReply Direct Link To This Post Topic: Minolta 100 2.8 macro cleaning & TC issue
    Posted: 08 January 2019 at 14:38
I recently bought a Minolta 100 2.8 Macro (1st version) from ebay and received it today. Upon visual inspection it appears it has lots of dust inside and something that looks like a couple fungus spots, also the focus is a bit hard - probably has dirt inside. I can't return as I bought with bank transfer (seller had no PP) and also because I got it fairly cheap (around Ä120) and I won't be able to find another at this level anytime soon.

I am thinking of opening and cleaning the lens, also putting new lubricants (I use silica oil) on the focus construction. As this is the most expensive(!) a-mount lens I have out of the 22 I bought the last 3 months I am kinda feeling bad to open it, I know it's a complex design but most of them are the same, just need to take care not to use force. Yesterday I opened and cleaned a newly-bought Minolta 50 2.8 Macro (fungus & focus grit) which I believe is the same design and it was quite easy to put back, easier than everything else I opened so far for cleaning (35-105/28-85/35-70/24-50/Tokina 28-70/28-135).

What I wanted to ask is if someone has experience opening both of them to confirm that their design is identical - bar the focus limiter button. That would make it much easier for me to open the lens for cleaning as I did the 50/2.8 twice for getting the hang of it (actually I forgot to put a screw).

Second question is referring to a TC. I bought this one: https://www.ebay.com/itm/Kenko-Konverter-Teleplus-2x-M-AF-MC7-f%C3%BCr-Minolta-AF-Sony-Alpha-A-Mount/312385135877?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649
It looks like new, probably never used. The problem is that it doesn't work with the LA-EA4 on my A7ii giving me F-- issue and both the seller is giving me hard time to return it despite me offering to cover both original and return shipping cost and ebay put a 10-day hold on the return, so I will just sell it back. From my understanding on the TC threads here I thought this one would work being a 3rd party, 5pin and probably not chipped. But it doesn't want. So now I am looking at an MC4 one from Kenko again which should be working. I only want it for the 70-210 & 75-300 lens as I don't want to buy a longer tele.

Before I go about selling it (and making a profit), is there perhaps a way to make it work? i.e. opening it and removing any chip it has inside which does not allow it to work with the LA-EA4? I saw a thread about chip replacements but I don't want to buy another one to get parts from, either I keep this one and fix it or I sell it and buy a working one.

Edited by sakisf - 08 January 2019 at 14:41
 



Back to Top
SnowFella View Drop Down
Senior Member
Senior Member

Joined: 21 April 2013
Country: Australia
Location: Sydney
Status: Offline
Posts: 2307
Post Options Post Options   Quote SnowFella Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 03:05
No idea if it's similar internally to the 50 2.8 Macro but in the below link you should be able to find the service manual to the original 100mm macro.

Minolta 100mm f/2.8 Macro
Back to Top
QuietOC View Drop Down
Senior Member
Senior Member

Joined: 28 February 2015
Country: United States
Location: Michigan
Status: Online
Posts: 2637
Post Options Post Options   Quote QuietOC Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 04:35
A non-chipped 2X teleconverter is not going to give you AF.

The 5-pin teleconverters are older and less reliable. I would recommend trying an 8-pin MC7.
Sony A7II A6000 A77II LA-EA3 LA-EA4 MC-11 MD-NEX KR-NEX DA-NEX
Minolta Maxxum 600si
Pentax Q7 5-15 15-45/2.8 8.5/1.9
Back to Top
SnowFella View Drop Down
Senior Member
Senior Member

Joined: 21 April 2013
Country: Australia
Location: Sydney
Status: Offline
Posts: 2307
Post Options Post Options   Quote SnowFella Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 07:32
Got to be a TC without a chip in it though I'd think or the LA-EA combo is likely to not work at all.
I've got an old non-chipped 1.7x TC and it will try to AF with any 5 pin lens I throw on it. IQ isn't exactly stellar to say the least though.
Back to Top
sakisf View Drop Down
Newbie
Newbie

Joined: 08 November 2018
Country: Greece
Location: Athens
Status: Offline
Posts: 12
Post Options Post Options   Quote sakisf Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 19:13
Originally posted by SnowFella SnowFella wrote:

No idea if it's similar internally to the 50 2.8 Macro but in the below link you should be able to find the service manual to the original 100mm macro.

Minolta 100mm f/2.8 Macro


Thank you, I forgot to check out the site, I usually try to find YT videos first just to make sure about the complexity and if I want to bother. Preparing the bench now, gloves on, hopefully it lives another day.

Originally posted by SnowFella SnowFella wrote:

Got to be a TC without a chip in it though I'd think or the LA-EA combo is likely to not work at all.
I've got an old non-chipped 1.7x TC and it will try to AF with any 5 pin lens I throw on it. IQ isn't exactly stellar to say the least though.


Actually there are people who say they used the TCs with LA-EA4 either with partial success (no correct EXIF) or with no issues at all and I remembered some saying to use unchipped 5pin TCs. Will make a try with another one and if it doesn't work I'll give up and maybe find a low priced A700 or 7D to use them on for crop effect.
Back to Top
sakisf View Drop Down
Newbie
Newbie

Joined: 08 November 2018
Country: Greece
Location: Athens
Status: Offline
Posts: 12
Post Options Post Options   Quote sakisf Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 19:16
Originally posted by QuietOC QuietOC wrote:

A non-chipped 2X teleconverter is not going to give you AF.

The 5-pin teleconverters are older and less reliable. I would recommend trying an 8-pin MC7.


I thought 8pin would cause more issues as they will be easier detectable by the LA-EA4. I am currently watching a Tamron 1.4x 5-pin and another Kenko 2x MC4 with 8pin. Will try to get both and if either works I'll be fine. Not sure I will ever use it but rather have one just in case (GAS)..
 



Back to Top
QuietOC View Drop Down
Senior Member
Senior Member

Joined: 28 February 2015
Country: United States
Location: Michigan
Status: Online
Posts: 2637
Post Options Post Options   Quote QuietOC Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 19:52
The only teleconverters that are detectable by the camera are the Sony and Minolta ones. Those are the ones that don't work with the LA-EA adapters. But I don't have the LA-EA4.

I recommend the Kenko DGX teleconverters. They are the most compatible ones--allowing AF with in-lens focus motors.

Edited by QuietOC - 09 January 2019 at 20:18
Sony A7II A6000 A77II LA-EA3 LA-EA4 MC-11 MD-NEX KR-NEX DA-NEX
Minolta Maxxum 600si
Pentax Q7 5-15 15-45/2.8 8.5/1.9
Back to Top
sakisf View Drop Down
Newbie
Newbie

Joined: 08 November 2018
Country: Greece
Location: Athens
Status: Offline
Posts: 12
Post Options Post Options   Quote sakisf Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 22:10
Originally posted by sakisf sakisf wrote:

Originally posted by SnowFella SnowFella wrote:

No idea if it's similar internally to the 50 2.8 Macro but in the below link you should be able to find the service manual to the original 100mm macro.

Minolta 100mm f/2.8 Macro


Thank you, I forgot to check out the site, I usually try to find YT videos first just to make sure about the complexity and if I want to bother. Preparing the bench now, gloves on, hopefully it lives another day.

Originally posted by SnowFella SnowFella wrote:

Got to be a TC without a chip in it though I'd think or the LA-EA combo is likely to not work at all.
I've got an old non-chipped 1.7x TC and it will try to AF with any 5 pin lens I throw on it. IQ isn't exactly stellar to say the least though.


Actually there are people who say they used the TCs with LA-EA4 either with partial success (no correct EXIF) or with no issues at all and I remembered some saying to use unchipped 5pin TCs. Will make a try with another one and if it doesn't work I'll give up and maybe find a low priced A700 or 7D to use them on for crop effect.


Just an update: reached the final barrel holding the lens elements and decided to leave them be. Had to remove an extra 13 screws there and then realign them (not so difficult) but instead chose to just push some air there to remove part of the dust and apply some silica oil on the focusing rails. The small fungus spot which might not be fungus can live for now, will come back to it another day if conditions worsen.



Regarding the focusing problem, which I believed was due to dirt inside, was actually due to two screws being not so tight and also the gears having dirt. I have cleaned them all and applied silica oil on the gears and on the screw walls on external focusing barrel and now it works like new. Previously the lens would seek focus, go to 1:1 from infinity and then stop. I thought it was a problem with the LA-EA4; now it would go to 1:1, back to infinity and back to 1:1 without issues. Focusing is actually much faster now as both focus barrels move much faster.

The construction quality of this lens is amazing. Such great detail in everything inside and technical superiority to anything else I have opened. There is only one weak spot and that is if the lens is dropped while fully extended and hitting at the lower part of the inside barrel and right on the aperture ring which might make it get stuck.

As for its sharpness, I have no words. It beats even my 35-105 (old) and 50 1.7 hands down. The macro 50 2.8 and Tokina 90 2.5 are getting close but not really there. Only has some small backfocus issue which I need to address with mAF.



Edited by sakisf - 09 January 2019 at 22:22
Back to Top
sakisf View Drop Down
Newbie
Newbie

Joined: 08 November 2018
Country: Greece
Location: Athens
Status: Offline
Posts: 12
Post Options Post Options   Quote sakisf Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 22:25
Originally posted by QuietOC QuietOC wrote:

The only teleconverters that are detectable by the camera are the Sony and Minolta ones. Those are the ones that don't work with the LA-EA adapters. But I don't have the LA-EA4.

I recommend the Kenko DGX teleconverters. They are the most compatible ones--allowing AF with in-lens focus motors.


I only have screw drive lenses - the newest of all being the Minolta 24-105, only one with 8 pins too. Anyway I will try to find a DGX one as prices lately seem to have gone up alot for any of the a-mount TCs.

Thank you for the recommendation :)
Back to Top
QuietOC View Drop Down
Senior Member
Senior Member

Joined: 28 February 2015
Country: United States
Location: Michigan
Status: Online
Posts: 2637
Post Options Post Options   Quote QuietOC Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2019 at 23:25
Originally posted by sakisf sakisf wrote:


I only have screw drive lenses - the newest of all being the Minolta 24-105, only one with 8 pins too. Anyway I will try to find a DGX one as prices lately seem to have gone up alot for any of the a-mount TCs.

I have bought quite a few. I should sell a few. The older 8-pin Kenkos should work fine with all of your lenses. They are also sold under other brand names including Tamron.

Edited by QuietOC - 09 January 2019 at 23:30
Sony A7II A6000 A77II LA-EA3 LA-EA4 MC-11 MD-NEX KR-NEX DA-NEX
Minolta Maxxum 600si
Pentax Q7 5-15 15-45/2.8 8.5/1.9
Back to Top
Kilkry View Drop Down
Senior Member
Senior Member

Joined: 06 August 2008
Country: Sweden
Location: ISO1600
Status: Offline
Posts: 2602
Post Options Post Options   Quote Kilkry Quote  Post ReplyReply Direct Link To This Post Posted: 10 January 2019 at 13:20
Well done!

I had the RS version, it had some CA wide open but was very sharp and had lovely bokeh. With the A77 it had the right ergonomics and stabilization, after that camera was lifted I tried using it with Sony's mirrorless with the LA-EA4 but found it too clunky (and no IS then). Haven't taken many interesting butterfly shots since..
-
Back to Top
ffrolvaag View Drop Down
Senior Member
Senior Member

Joined: 16 November 2007
Country: United States
Location: United States
Status: Offline
Posts: 1063
Post Options Post Options   Quote ffrolvaag Quote  Post ReplyReply Direct Link To This Post Posted: 11 January 2019 at 00:46
Nice job. Sorry I didnít respond sooner, but I have fully didassebled both individually. My recollection is that they are of similar construction, but the 100mm is a bit more complex. However, if you get a bit further into them you should be able to carefully clean out the dust. If you go beyond where you are, it is a much longer job. The first time I did a full tear down of a 100mm macro, it took me 6 hours. The second one I did took 3, an then the third time, was only 2. The 50 mm was about a 2 hour job, but was much later when I already had experience with the others.

Franz



a900, a700, 5600hs, 1200 (w/MFC-1000), 3x converted f1.2 (Rokkor 58, Nikon 50 ais, and Pentax 50), 85mm f1.4, 100mm f2.8, 70-400G, and way too much other stuff to mention
Back to Top
jackal2008 View Drop Down
Newbie
Newbie

Joined: 08 March 2018
Country: Canada
Status: Offline
Posts: 24
Post Options Post Options   Quote jackal2008 Quote  Post ReplyReply Direct Link To This Post Posted: 11 January 2019 at 07:04
My copy of 100 macro would stuck some time. Wondering how difficult it is to just lubricate focus part. If you have some photos, would you mind sharing a bit? Thanks.
Back to Top
sakisf View Drop Down
Newbie
Newbie

Joined: 08 November 2018
Country: Greece
Location: Athens
Status: Offline
Posts: 12
Post Options Post Options   Quote sakisf Quote  Post ReplyReply Direct Link To This Post Posted: 11 January 2019 at 07:15
Originally posted by ffrolvaag ffrolvaag wrote:

Nice job. Sorry I didnít respond sooner, but I have fully didassebled both individually. My recollection is that they are of similar construction, but the 100mm is a bit more complex. However, if you get a bit further into them you should be able to carefully clean out the dust. If you go beyond where you are, it is a much longer job. The first time I did a full tear down of a 100mm macro, it took me 6 hours. The second one I did took 3, an then the third time, was only 2. The 50 mm was about a 2 hour job, but was much later when I already had experience with the others.



Thank you. I figured it would be very difficult as soon as I saw the number of screws I had to undo to get in further; also the repair diagram was not very clear on how you put the last two focusing barrels together (alignment). Will see if dust affects the image considerably, if not I will leave it untouched for some time.

At least through the openings I had access to the 2 rearward lenses and managed to remove most of the dust there.

I am almost the same regarding timings with each lens i.e. I opened 3 35-70s 2 times each and now I can do it in less than 30 minutes. That was the first lens I opened for cleaning and it took me ~8 hours Most are the same, some are more difficult to put back because you have to be careful with the alignment of the focusing barrel, though not as bad as older MD lenses. I am now waiting an AF 135 2.8 with fungus, probably the second to last Minolta AF I am buying for some time as I now have many overlapping ones and need to start shooting more and maybe sell some back. The last one I am looking at now is the Sigma 12-24 for the UWA part and then I am done.

Edited by sakisf - 11 January 2019 at 07:33
Back to Top
Dyxum main page >  Forum Home > Equipment forums > Lens Talk > A-mount lenses Page  12>

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.

Monitor calibration strip

Dyxum.com - Home of the alpha system photographer

In memory of Cameron Hill - brettania

Feel free to contact us if needed.