FAQ FAQ  Forum Search   Events   Register Register  Login Login

Repairing a Sigma 70-210 f/2.8

Page  <1 234
Author
Osi View Drop Down
Newbie
Newbie

Joined: 31 March 2020
Country: Nigeria
Status: Offline
Posts: 12
Post Options Post Options   Quote Osi Quote  Post ReplyReply Direct Link To This Post Posted: 30 May 2020 at 17:29
Originally posted by neilt3 neilt3 wrote:

Hi Osi .
That's a sickner losing your phone with all the images on , I know how valuable they are for reference .
.


My dear brother, if I lost only my phone with disassembled electronics, that's pretty painful; but it was my entire record of uncountable bookmarked pages,apps, settings, maybe over 19,000 images and thousands of video clipses on various subjects - most simply irreplaceable. I last backed up a full year previously. What I could get hardly represented 10% of what I lost. It feels worse than the death of a human being. I was willing to pay more than the value of the phone to get my information back, but when you misplace your phone in Nigeria, my brother, please forget it. The first thing they do is switch it off and throw away the SIM card and you can't contact them again. They're incapable of considering how vital information in a phone can be.

Edited by Osi - 30 May 2020 at 17:32
 



Back to Top
neilt3 View Drop Down
Senior Member
Senior Member

Joined: 13 September 2010
Country: United Kingdom
Location: Manchester.U.K
Status: Offline
Posts: 2404
Post Options Post Options   Quote neilt3 Quote  Post ReplyReply Direct Link To This Post Posted: 03 June 2020 at 00:48
Originally posted by Osi Osi wrote:

Hi. I have sent a message to the e-mail address you provided, with pictures. They were supposed to be for me only. If I knew I would be sharing them with the world, I'd have done a better job of it. Fun fact: I'm in Nigeria!


Hi Osi .

Here are the photos you sent me , hopefully they may be of use to someone doing a search for them .

sigma lens by Neil Taylor, on Flickr

sigma lens 2 by Neil Taylor, on Flickr
see my photostream on flickr;
http://www.flickr.com/photos/neilt3/
C & C welcome.
Back to Top
beeton View Drop Down
Groupie
Groupie

Joined: 02 December 2014
Country: Canada
Location: Beeton
Status: Offline
Posts: 67
Post Options Post Options   Quote beeton Quote  Post ReplyReply Direct Link To This Post Posted: 28 June 2020 at 02:49
I have conquered Mount ZEN. Took much work but I have removed and cleaned the slightly foggy element from my Sigma 70-210 f2.8 Zen

History is written up on the fist page. I was having trouble getting consistent micro-focus correct images as the setting required seemed to jump between +9 and -9. That is a huge range. I found then that there was a little slop in the focus ring and even when focus was on, a slight wiggle of the barrel would throw it off. So, I decided to take the lens apart to see if I had a loose gear or something else causing the play. When taking the lens apart, I removed the front-inner cell, the one with the hazy element, as a group. This was done after removing the front ring from the inside, under the objective. Removing that ring exposes the screws that have to be removed to fully pull out the lens group. This ring is a friction-fit. To remove it, I had to use a plastic cap and a rubber ring (lens grip ring from an old lens) and twist off the ring. Once the screws are out (only the 3 outer have to be removed), the lens group can be pulled out from the back. Once done, you have to remove the retaining ring from the BACK of the metal cell in the same fashion as the front ring but with a smaller cap or insert. You can then pull out the inner cell with the elements. There are 3 elements within- one at front and a doublet at back. To remove the elements itself was a challenge. There is no spanner inset for the front ring or rear. The font had locktite and I had to add a bit of nail polish remover to the gap between the threads top dissolve that (don't get any on the elements). Then, remove the front ring by applying a bit of pressure to the ring face (inside, not top and try to push counter-clockwise. BE CAREFUL not to scratch the element or jab yourself. BEFORE YOU REMOVE THE ELEMENTS, TAKE NOTE OF THEIR ORIENTATION. I put it all back together only to realize I had reversed the front element and had to start over.

Cleaned up the haze and lens works great BUT still that play in focus...will have to be careful on shoots. Took some test images. This is a very nice lens. Sharp and except for some vignetting at 2.8 and a bit of loss in the edges, which almost lenses suffer wide open, very good performer. I will try to post some images.
Back to Top
Dyxum main page >  Forum Home > Equipment forums > Lens Talk > A-mount lenses Page  <1 234

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.

Monitor calibration strip

Dyxum.com - Home of the alpha system photographer

In memory of Cameron Hill - brettania

Feel free to contact us if needed.