FAQ FAQ  Forum Search   Events   Register Register  Login Login

Sony a77ii card slot assembly/repair

Page  12>
Author
addy landzaat View Drop Down
Senior Member
Senior Member

Joined: 22 April 2006
Country: Netherlands
Location: Netherlands
Status: Offline
Posts: 14808
Post Options Post Options   Quote addy landzaat Quote  Post ReplyReply Direct Link To This Post Topic: Sony a77ii card slot assembly/repair
    Posted: 07 March 2023 at 17:20
If it is a Minolta 5D then it was Compact Flash (CF) memory card. Probably a broken pin. The A77m2 has a SD card, different card.
Why not follow me on Instagram? @Addy_101
 



Back to Top
vitor View Drop Down
Senior Member
Senior Member

Joined: 10 August 2006
Country: Portugal
Location: Lisbon
Status: Offline
Posts: 2027
Post Options Post Options   Quote vitor Quote  Post ReplyReply Direct Link To This Post Posted: 07 March 2023 at 15:09
Originally posted by Miranda F Miranda F wrote:

Originally posted by vitor vitor wrote:

It seems that it has some damage on the pins. It might be possible to find parts and replace the slot.
Let me know if your willing to sell. I might try to fix it.

I have a 5D with damage to a pin and it was not repairable.


Do you know why it was not repairable?
Did the broken pin stripted a pcb track? Sometimes its possible to use a emanel wire to recreate the track.
And some cameras have the card slot on a external pcb.

Its always a gamble trying to fix electronic equipment
Back to Top
Miranda F View Drop Down
Senior Member
Senior Member

Joined: 11 January 2014
Country: United Kingdom
Location: Bristol
Status: Offline
Posts: 4073
Post Options Post Options   Quote Miranda F Quote  Post ReplyReply Direct Link To This Post Posted: 07 March 2023 at 13:31
Originally posted by vitor vitor wrote:

It seems that it has some damage on the pins. It might be possible to find parts and replace the slot.
Let me know if your willing to sell. I might try to fix it.

I have a 5D with damage to a pin and it was not repairable.
Miranda F & Sensorex, Sony A7Rii, A58, Nex-6, Dynax 4, 5, 60, 500si/600si/700si/800si, various Sony & Minolta lenses, several Tamrons, lots of MF primes and *far* too many old film cameras ...
Back to Top
japp View Drop Down
Newbie
Newbie

Joined: 25 March 2021
Country: Netherlands
Status: Offline
Posts: 38
Post Options Post Options   Quote japp Quote  Post ReplyReply Direct Link To This Post Posted: 23 February 2023 at 15:17
oh, and if you don't yet want to do away with this a77ii you can always use it as an webcam for the moment.
Back to Top
japp View Drop Down
Newbie
Newbie

Joined: 25 March 2021
Country: Netherlands
Status: Offline
Posts: 38
Post Options Post Options   Quote japp Quote  Post ReplyReply Direct Link To This Post Posted: 21 February 2023 at 10:55
if you indeed want to sell i am also intrested as i am currently only using the a68 and have some history with repair.
Back to Top
vitor View Drop Down
Senior Member
Senior Member

Joined: 10 August 2006
Country: Portugal
Location: Lisbon
Status: Offline
Posts: 2027
Post Options Post Options   Quote vitor Quote  Post ReplyReply Direct Link To This Post Posted: 21 February 2023 at 10:06
It seems that it has some damage on the pins. It might be possible to find parts and replace the slot.
Let me know if your willing to sell. I might try to fix it.
 



Back to Top
Badr View Drop Down
Newbie
Newbie

Joined: 02 February 2018
Country: United Kingdom
Location: Newcastle upon
Status: Offline
Posts: 21
Post Options Post Options   Quote Badr Quote  Post ReplyReply Direct Link To This Post Posted: 20 February 2023 at 18:37
Thanks all
It seems that the damage is more than I thought.
Today, I decided to try again, I cut a piece of a roll of film and managed to pass it all the way. Then I made the card slide on the film to avoid the parts from the side coming out. With a bit of force it went in all the way. Not only that, it behaved like a normal card with the click. Very happily ran to find the battery and was treated by «No card». I then tried 4 different cards with no avail.

I might try and sell it as spare or repair and wait for a functioning one for a good price.
I have a few older a mount bodies but this feels way different experience, even compared to the a68 with the same af system it feels more joyful to use.
I also have a7ii for manual glass but never felt connected to it.
Thanks again for replying
Badr

Edited by Badr - 20 February 2023 at 18:40
Back to Top
Phil Wood View Drop Down
Senior Member
Senior Member

Joined: 24 March 2013
Country: United Kingdom
Location: England
Status: Offline
Posts: 2935
Post Options Post Options   Quote Phil Wood Quote  Post ReplyReply Direct Link To This Post Posted: 20 February 2023 at 18:31
I had a problem with one of the slots on my A99ii - a card would go in but it would not lock in. I'm 95% sure the problem was caused by a foreign body in the mechanism viz one of the little plastic sliders that sets the SD card to read/write or read only. After using the other slot alone for a few months I tried again and it worked - hopefully the foreign body fell out, but I fear it's still in there somewhere. Nowadays I glue the little blighters in the read/write position.

The point is that there might be something like this blocking your slot.
Back to Top
LAbernethy View Drop Down
Senior Member
Senior Member

Joined: 25 November 2015
Country: Canada
Location: Ontario
Status: Offline
Posts: 3330
Post Options Post Options   Quote LAbernethy Quote  Post ReplyReply Direct Link To This Post Posted: 20 February 2023 at 13:24
Originally posted by owenn01 owenn01 wrote:

It seems the old card had 'swelled' over time (heat perhaps?) and just fouled the card slot about 60 - 70% of the way into the slot.

Might be worth trying another (or new) card if you have one, just in case?


I've had that happen with Memory Cards and batteries.
Back to Top
owenn01 View Drop Down
Alpha Eyes group
Alpha Eyes group

Joined: 20 May 2008
Country: United Kingdom
Location: Kent
Status: Offline
Posts: 12171
Post Options Post Options   Quote owenn01 Quote  Post ReplyReply Direct Link To This Post Posted: 20 February 2023 at 12:22
Hi Badr - a slightly 'off the wall' comment here but I had an almost identical issue arise with my a99 a little while ago; I started to experience what seemed like a jamming of the card in the slot?

I tried the same card in an a77ii and it was fine but not in the a99. I then tried a new card in the a99 and it worked fine! It seems the old card had 'swelled' over time (heat perhaps?) and just fouled the card slot about 60 - 70% of the way into the slot.

Might be worth trying another (or new) card if you have one, just in case?

Good luck and best regards, Neil.
My Mantra: "Comment on other's work as you would wish to have yours commented upon". Go on - it's fun!
Back to Top
Badr View Drop Down
Newbie
Newbie

Joined: 02 February 2018
Country: United Kingdom
Location: Newcastle upon
Status: Offline
Posts: 21
Post Options Post Options   Quote Badr Quote  Post ReplyReply Direct Link To This Post Posted: 19 February 2023 at 19:20
Hi Neil
Very likely that that contacts are working if the card gets in, so disassembly might work like you said. I may give it a go as a last option, thinking that it may be too complicated for me. (Although with some help from YouTube I recently managed to successfully convert a Nikon d70 to IR, a77ii seems too complicated and no resources).

I will keep trying
Back to Top
amrep View Drop Down
Senior Member
Senior Member

Joined: 02 February 2015
Country: Norway
Status: Offline
Posts: 313
Post Options Post Options   Quote amrep Quote  Post ReplyReply Direct Link To This Post Posted: 19 February 2023 at 17:26
Originally posted by Badr Badr wrote:

I had a look inside and there is no foreign object but the cage inside doesn’t look as my a68.

I thought this was strange, because the A68 is basically an economy version of the A77ii and should have the same card slot, so I wanted to compare. Now I did, and to me they look 100% identical.

If you can see something that differs from the slot of your working A68, then you actually see what causes the problem. As I suggested previously, it may be wise to look thoroughly.
Back to Top
neilt3 View Drop Down
Senior Member
Senior Member

Joined: 13 September 2010
Country: United Kingdom
Location: Manchester.U.K
Status: Offline
Posts: 3235
Post Options Post Options   Quote neilt3 Quote  Post ReplyReply Direct Link To This Post Posted: 19 February 2023 at 16:54
Sometimes when I've bought a new camera I've found the card goes in opposite what I'm used to . IE the contacts are facing you rather than away from you , or visa versa .
So just a long shot ( and I'm sure you've checked ) but are you putting the card in the right way around ?

Secondly , if it's just part of the frame that's got physically bent somehow, when you strip the camera down to get to it , it might just bend back , rather need replacing .
see my photostream on flickr;
http://www.flickr.com/photos/neilt3/
C & C welcome.
Back to Top
Badr View Drop Down
Newbie
Newbie

Joined: 02 February 2018
Country: United Kingdom
Location: Newcastle upon
Status: Offline
Posts: 21
Post Options Post Options   Quote Badr Quote  Post ReplyReply Direct Link To This Post Posted: 19 February 2023 at 16:03
Thanks Amrep,

I will try the memory stick card, just bought an adapter after reading your post.
I will keep trying and if I ever manage to get a card in, it will never come out ll
Back to Top
Dyxum main page >  Forum Home > Equipment forums > Camera Talk > A-mount APS-C Page  12>

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.

Monitor calibration strip

Dyxum.com - Home of the alpha system photographer

In memory of Cameron Hill - brettania

Feel free to contact us if needed.